“HTML preview not available” – Die Meldung nervt dich auch? Kein Problem, ich schaffe für Abhilfe:

  1. Die CLI-Version von PHP muss auf dem System installiert sein. Sollte dies aus irgendeinem Grunde nicht der Fall sein – ich gehe einmal davon aus, dass keiner mehr PHP4 anfasst und das ernsthafte Tracs auf einem Unix-System liegen!: sudo aptitude install php5-cli

  2. Nachdem man nun weiß, wo PHP-CLI liegt (wahrscheinlich /usr/bin/php5-cli), sucht man nun die trac.ini seines Projektes. Je nach Installation könnte das zum Beispiel in /var/trac/meinprojekt/conf/trac.ini sein.

  3. Dort muss eine Einstellung hinzugefügt werden, a la

    php_path = /usr/bin/php5-cli
    

    TracFaq